DISEÑO Y MAQUETADO DE PLANTILLAS WEB 1 

Con Adobe Photoshop y Macromedia Dreamweaver

En las 4 entregas anteriores de DISEÑO DE INTERFACES WEB, vimos junto a Paquo360 como crear una plantilla usando Adobe Photoshop, quedo pendiente el maquetado de la misma con Dreamweaver, eso veremos ahora.

Nota: Si bien fue desarrollado en Photoshop 6, se puede ejecutar en Photoshop CS 2 sin problemas, al igual que usar Dreamweaver 8 para el maquetado. !!

Este fue el comienzo de nuestro Primer Gran Tutorial en el año 2002, en el Viajaremos a través de 4 distintas aplicaciones de Diseño Web como lo son: El magnifico "Photoshop", su inseparable "Image Ready", el tan popular "Front Page" versión 2000 (tambien se puede aplicar el 2003) y el completísimo "Dreamweaver" versión 4 (o superiores hasta la actual DW 8). Recordamos que en este tipo de Tutoriales la explicación esta dada para personas que ya tienen un conocimiento previo del programa aunque sea minimo (si quedan dudas pueden consultarlas en el foro), pues la extensión del mismo no permite que nos detengamos a detallar cada uno de los pasos. Si no cuentas con un conocimiento medio de Photoshop, tendrás dificultades para entenderlo, lo que significa que difícilmente lo acabarás; y aconsejamos por ello leer antes nuestros tutoriales basico, recomendamos que empieces por los tutoriales de texto, botones y retoque, te aseguramos que entonces estarás más que capacitado para entender este Tutorial.

Este es el diseño de Pagina que usaremos. Como verás es mas adecuada para un portal que para pagina personal.

Provisionalmente hemos colocado el nombre a las distintas ventanas, sin embargo al final eres tú quien decide en qué usar en cada una de ellas.

Nota:
En delante, por cuestión de espacio visible, trabajaremos sin nombre sobre las ventanas. Si así lo deseas hacer también sólo bórralos.

Recomendación:
Te sugerimos que después de cada tres o cuatro pasos guardes tu trabajo, pero con un nombre diferente. Esto para evitar errores irreparables. Podrías llamarlo "pagina1" luego aplicas "Guardar Como" y llamas al segundo "pagina2", y si al final estas conforme con tu trabajo puedes borrar los archivos que ya no te sirvan.


Hay que crear selecciones para cada ventana y luego rellenarlas con color.

La primera será la más complicada.

Para elaborar las selecciones es imperante que acoplemos bien una guía por cada línea y/o punto de inclinación que veamos en el dibujo, en este caso en la primera barra, la del logotipo y banner de publicidad.

La imagen te muestra el resultado: 6 guías verticales y 6 horizontales.

[image: image1.png]Rl

Ll

—

——————

i ——





En el tutorial de Interface Básica encuentras una más amplia explicación de las Guías, Reglas y Selecciones.

Para aparecer u ocultar las reglas presiona "Ctrl + R"
Para aparecer u ocultar las guías presiona "Ctrl + ' "
Dentro del menú View activa el Snap (salto) para asegurarnos de que la selección se base en las guías. Si deseas ser mas específico dirígete a:
"Snap to > Guides"
Toma la herramienta Rectangular Marquee [image: image2.png]


y traza la primera selección.
La imagen te muestra el resultado.
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Ahora tenemos un largo rectángulo, sin embargo no es la figura que necesitamos.

Hay que recortar las esquinas de nuestra Selección para acoplarla a nuestro diseño.

Hay mucha mas comodidad y precisión con un Zoom ([image: image4.png]


) de 300%.

Toma la herramienta Polygonal Lasso [image: image5.png]


y presionando la tecla Alt crea un triángulo. Cuando cierres el triángulo cerciórate de ver un pequeño círculo, el cual te indica que lo haces en el lugar adecuado, donde se unen las puntas y se cierra el triángulo.

Al soltar la tecla Alt el área que ocupaba el triangulo, dentro de la Selección, desaparece.

La imagen te muestra el antes y después de soltar la tecla Alt .

Repite la operación en las cuatro esquinas de nuestra Selección.

Si en algún momento las guías te molestan por atraer la Selección a donde no deseas, desactiva el Snap.
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La siguiente área a tratar es el área de publicidad o banner. Si no lo consideras necesario para tu página salta a la siguiente etapa.

Presiona "Ctrl + ' " o en el menú "View > Snap To > Guides" para ver las líneas del bosquejo que tenemos tras las guías e identifica la posición del banner.

Haz lo contrario para volverlas a ver y continuar.

Toma la herramienta Rectangular Marquee [image: image8.png]


y presionando la tecla Alt crea una selección siguiendo las guías.

La imagen te muestra el resultado.

[image: image9.png]



Guarda la selección. "Selection > Save Selection" y nómbrala Banner. Luego presiona "Ctrl + D" para quitarla y continuar.

La siguiente selección es la pestaña inferior izquierda de la barra de título.

Lo haremos en tres pasos, como lo muestran las imágenes.

1 .- Crea la selección basado en las guías. Ojo: he movido una guía central que estorbaba.

2 .- Luego: "Select > Transform Selection" con esto se forma un recuadro alrededor de la selección. Sigue con "Edit > Transform > Skew" con esto puedes tomar las esquinas inferiores del recuadro y arrastrarlas hasta los puntos rojos de la imagen 1 (en la intersección).

[image: image10.png]



3 .- Una vez colocadas las esquinas correctamente presiona Enter en tu teclado para aceptar la selección creada. La imagen 3 te muestra el resultado.

Guarda la selección con el nombre de Pestaña.

DISEÑO Y MAQUETADO DE PLANTILLAS WEB 2 

Con Adobe Photoshop y Macromedia Dreamweaver

Continuamos con la segunda entrega junto a Paquo360 que nos enseña como crear una plantilla usando Adobe Photoshop, y luego maquetarla con Macromedia Dreamweaver.

Nota: Si bien fue desarrollado en Photoshop 6, se puede ejecutar en Photoshop CS 2 sin problemas, al igual que usar Dreamweaver 8 para el maquetado. !!

Carga la selección Banner pues con esta empezamos a dar color a las capas.

[image: image11.png]



Crea una Nueva Capa y nómbrala Banner. Sobre esta carga la selección llamada Banner "Select > Load Selection" Rellenarla con un color Gris Oscuro (999999)

Luego carga la selección Pestaña y presiona Supr (delete) , esto elimina esa área de la Capa Banner.

Crea una Nueva Capa y nómbrala Pestaña. Rellena el área de la selección Pestaña con un color gris más claro (CCCCCC)

[image: image12.png]



Crea la selección basado en las guías. Ojo: he movido una guía central que estorbaba.

Finalmente hagámoslo con una de las ventanas, la del menú:

1. - Acopla las guías sobre las líneas de la ventana.
2. - Traza la selección Mayor siguiendo las guías.
3. - Sobre una Nueva Capa (menú) rellena la selección con gris claro (CCCCCC)
4. - Dibuja la segunda selección (superior) y en una Nueva Capa (menú 1) rellena con un gris oscuro (999999)

Presiona "Ctrl + D" para deseleccionar y listo.
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Con la misma técnica puedes terminar el resto de las ventanas.
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Aquí tienes las capas con color (no definitivo), y los nombres asignados a cada una.

[image: image15.png]



Busca la imagen en la Carpeta Almacén

El siguiente paso será crear el estilo de capa requerido para darle profundidad a la plantilla.

DISEÑO Y MAQUETADO DE PLANTILLAS WEB 3

Con Adobe Photoshop y Macromedia Dreamweaver

Continuamos con la tercer entrega junto a Paquo360 que nos enseña como crear una plantilla usando Adobe Photoshop, y luego maquetarla con Macromedia Dreamweaver.

Nota: Si bien fue desarrollado en Photoshop 6, se puede ejecutar en Photoshop CS 2 sin problemas, al igual que usar Dreamweaver 8 para el maquetado. !!

Este es el diseño con el que terminamos la anterior página. El siguiente paso es darle profundidad. Para esto hay que crear un estilo de capa, el cual es muy sencillo.

Para una más amplia explicación sobre los estilos de capa visita el tutorial "Botón con Estilos"
[image: image16.png]



Para ese nuevo estilo de capa solo marca los mismos valores que las imágenes te mostrarán.
Aquí vamos con Drop Shadow (Sombra Paralela).
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Aquí vamos con Inner Shadow (Sombra Interior).
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Este es Bevel and Emboss (Bisel y Relieve).
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Y finalmente Stroke (color=666666)
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Guarda el estilo de capa creado presionando New Style (Nuevo Estilo).
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DISEÑO Y MAQUETADO DE PLANTILLAS WEB 4

Con Adobe Photoshop y Macromedia Dreamweaver

Continuamos con la cuarta entrega junto a Paquo360 que nos enseña como crear una plantilla usando Adobe Photoshop, y luego maquetarla con Macromedia Dreamweaver.

Nota: Si bien fue desarrollado en Photoshop 6, se puede ejecutar en Photoshop CS 2 sin problemas, al igual que usar Dreamweaver 8 para el maquetado. !!

Aplica el estilo creado a todas las capas de color gris oscuro en el diseño.
En el caso de la capa "Pestaña", que es de color gris claro, aplica y luego desactiva Bevel and Emboss y Drop Shadow.
La imagen te muestra el resultado.

[image: image22.png]



Debido al Borde creado por la aplicación de Stroke el tamaño de las ventanas ha rebasado el de la capa "Pantalla". Te recomiendo que, con un Zoom de 300-500 y unas guías corrijas, presiona "Ctrl + T" y aumenta la altura de esta capa. Esto puede evitarte mayores contratiempos con los editores HTML.

[image: image23.png]



Hay que mejorar la nitidez de los bordes finos del diseño, lo cual se logra muy fácilmente con "Levels".

En una capa de ajuste (Layer > New Layer Adjustmenet > Levels) presiona el Auto, luego corre el triángulo central hasta un valor de 2.20 (eres libre de usar tus propios valores).

La imagen te muestra los valores en el Canal RGB.
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Ahora viene el color, el cual es muy sencillo de cambiar. Asegúrate de estar sobre la capa superior del PSD.

Luego: "Layer > New Adjustment Layer > Hue/Saturation"

La imagen te muestra los valores que usé.

Para encontrar el color adecuado a tus necesidades juega primeramente con Hue y luego encuentra la intensidad de este con Saturation.

Lightness no es muy recomendable a menos que desees quitar o poner más luz.

Te recomendamos usar nuestro valores hasta terminar este tutorial, luego podrás cambiarlos si así lo deseas.
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Este es nuestro resultado después de la coloración.

[image: image26.png]



Finalmente decoras tu Web. Nosotros, por cuestiones de tiempo, lo hicimos muy poco, pero no es tu caso, es aquí donde tu creatividad debe relucir.

El fondo lo rellenamos con un color amarillo muy claro (FBFB74).

[image: image27.png]



Hasta aquí llega "Photoshop" pero toma su lugar el Hermano Menor "Image Ready".

DISEÑO Y MAQUETADO DE PLANTILLAS WEB 5

Con Adobe Photoshop y Macromedia Dreamweaver

Continuamos con la quinta entrega junto a Paquo360 que nos enseña como crear una plantilla usando Adobe Photoshop, y luego maquetarla con Macromedia Dreamweaver.

Nota: Si bien fue desarrollado en Photoshop 6, se puede ejecutar en Photoshop CS 2 sin problemas, al igual que usar Dreamweaver 8 para el maquetado. !!

Este es el resultado hasta ahora y es aquí donde abandonamos "Photoshop" y entramos a "Image Ready". Sólo presiona el botón "Jump To Image Ready" [image: image28.png]


.

En delante lo que buscamos es hacer que nuestra imagen, la cual tiene un considerable peso en bytes, sea más ligera y así ayudar al la rápida carga de la misma en Internet.

[image: image29.png]



Tal vez sea esta sea la primera imagen que tengas de Image Ready, mas aun si lo usas poco.

Rápidamente, reconfiguremos las ventanas. Necesitaremos las ventanas de Optimize, Layers, History, Slice y el Menú de Herramientas. Al resto lo puedes quitar para tener más espacio y no ser objeto de este tutorial.

Asegúrate de que el Snap, en el menú View, no esta activado, entonces empieza a cortar.

[image: image30.png]



Toma el Cuchillo (Slice) [image: image31.png]


. Lo primero que cortaremos es el Menú. Cuando tus cortes no sean exactos usa el Slice Select [image: image32.png]


que es el editor de cortes, o simplemente presiona Supr (delete) en tu teclado y vuelve a trazarlo.

Es recomendable usar continuamente El Zoom [image: image33.png]


y Hand [image: image34.png]


para moverte a través de la imagen.

Vemos que al trazar el primer corte automáticamente se generan otros cortes. Por esto es importante tomar en cuenta que entre menos colores y cortes usemos menor será el peso de nuestra página, osea que tardará menos en cargarse.

Luego de esto continuemos con el resto del menú en un nuevo corte, el cual también abarca un poco de fondo claro, para evitar crear mas celdas.
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Las imágenes de un sólo color pueden ser sustituidas por color de fondo de celda en el Editor HTML, lo que agiliza la carga de la página.

Con los cortes lo que se intenta es separar las zonas de un solo color de las que están compuestas por un conjunto de estos, como las imágenes con profundidad.

Aquí tenemos los cortes generados para esta plantilla.

[image: image36.png]



Aquí esta la imagen hasta el momento, en mayor tamaño.
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DISEÑO Y MAQUETADO DE PLANTILLAS WEB 6

Con Adobe Photoshop y Macromedia Dreamweaver

Continuamos con la sexta entrega junto a Paquo360 que nos enseña como crear una plantilla usando Adobe Photoshop, y luego maquetarla con Macromedia Dreamweaver.

Nota: Si bien fue desarrollado en Photoshop 6, se puede ejecutar en Photoshop CS 2 sin problemas, al igual que usar Dreamweaver 8 para el maquetado. !!

Una vez hechos los cortes, optimizaremos las imágenes que lo requieran, pues las de un solo color regularmente se sustituyen por una celda con fondo del mismo color de la imagen, a estas no las trates si no lo deseas, pues las eliminaremos.

Image Ready nombra automáticamente las imágenes de tu diseño una vez cortadas, sin embargo es preferible que seas tu quien las nombre para poder identificarlas fácilmente en el Editor HTML. En este caso Ejemplificaremos con la imagen de nuestro Logo "Web Muestra" Toma Slice Select para, como su nombre lo dice, seleccionar este Corte, el #03 de la imagen. Nos indica también que tiene un peso de 5.767K en formato Gif. Selecciona Tipo Imagen y hemos escogido el Nombre logo.
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En el caso de que gustes agregar un Hipervínculo a la imagen hazlo desde URL: y el tipo de ventana desde Target, en este caso _blank para una Nueva Ventana. Finalmente BG se usa para conjugar tu imagen con algún color de fondo.

En este tutorial sólo usaremos el menú Slice para nombrar nuestras imágenes, el resto lo dejaremos en blanco o como este.

Mucho facilita el trabajo reconocer las imágenes por el nombre que les diste, por eso recomendamos dar nombres muy claros e identificables.

Una vez que hayas nombrado las imágenes colócate sobre las pestañas Optimize, tanto de Pantalla como Paleta. Utiliza estos valores en todas las imágenes importantes; tan solo 32 colores debido a que nuestro diseño, que tal vez no te diste cuenta, fue preparado con una paleta de colores lista para la Web, lo que nos facilita una alta calidad con pocos colores, podrías usar incluso 16 colores y no sería tan notorio, sin embargo a mi juicio 32 es exacto. Manejamos el formato Gíf por ser un diseño creado con computadora y con poca coloración, sin embargo con un Lossy de 0 para mantener la calidad visual.
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Un método Selectivo de color y con Diffusion como método de distribución. El Dither de 100%, que usualmente no es muy usado, a nosotros nos agrada pues preferimos unos cuantos Bytes de sobrepeso que una imagen con marcadas bandas de color y más con esta que es la imagen principal de nuestro diseño.

Presionando [image: image40]en la Barra de Herramientas puedes previsualizar tu Página en el explorador.

Y además de la previsualización nos proporciona los siguientes datos.

Formato de Imágenes: GIF
Dimensiones: 780w x 750h
Tamaño: 20.85K
Imagenes: 35
Valores: Selective, 100% Diffusion Dither, Non-Interlaced, 0% Web Snap
Codigo Fuente: (HTML)

[image: image41.png]



Finalmente hay que guardar la plantilla, pero ahora como HTML e imágenes.

File > Save Optimzed As
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Hasta aquí llega "Image Ready" ahora son los editores HTML Front Page y/o Dreamweaver.

DISEÑO Y MAQUETADO DE PLANTILLAS WEB 7

Con Adobe Photoshop, Microsoft Front Page y Macromedia Dreamweaver

Continuamos con la septima entrega junto a Paquo360 que nos enseña como crear una plantilla usando Adobe Photoshop, y luego maquetarla con Macromedia Dreamweaver, pero debido a algunos pedidos de usuarios haremos primero la Maquetacion en Microsoft Front Page :) 

Nota: Si bien fue desarrollado en Photoshop 6, se puede ejecutar en Photoshop CS 2 sin problemas, al igual que usar Dreamweaver 8 para el maquetado. !!

Abre tu diseño de Página, ahora en HTML. La Primera impresión en Front Page 2000 o superior es un poco tosca (ruda) pues las celdas aparentan estar fuera de lugar, sin embargo no es así y lo puedes comprobar en la Vista Previa [image: image43.png]


.

Lo primero que haremos será cambiar el color del fondo de nuestra Página.

[image: image44.png]‘, —




Formato > Fondo > Colores > Fondo > más colores > Valor = EC,ED,F7.

Con esto se homogeniza el fondo de nuestra página y estamos en posibilidades de eliminar las imágenes cuyo color es el mismo que el de fondo. Sólo haz clic sobre estas y luego presiona Supr (delete), no importa que cambie el tamaño de la celda. Si tienes duda, en cualquier momento puedes comprobar que tu celdas aun concuerdan con la Vista Previa
Evita en todo momento hacer un cambio a las celdas de los extremos superior y derecho, pues son estas las que dan estabilidad a tus tablas.

Ahora ve a la pestaña HTML y busca lo siguiente (6, 7, o 8 línea):

[image: image45.png]



Debajo encontrarás el siguiente código. Agrega el comando ALIGN.

<TABLE WIDTH=780 BORDER=0 CELLPADDING=0 CELLSPACING=0>
<TABLE WIDTH=780 BORDER=0 CELLPADDING=0 CELLSPACING=0 ALIGN=CENTER>
Con esto tu Plantilla se centra sobre la página como en la imagen. 

Hasta ahora mi contador [image: image46.png]


de Tiempo estimado de carga marca 15 seg. a 28.8 kb/s, es decir que si tienes una velocidad de conexión a Internet de 56 kb/s tu Plantilla se cargará en 7.5 segundos (la mitad). Sin duda es una tentadora marca, sin embargo hay que pensar en que se le agregarán más celdas, scripts, imágenes y muchas otras cosas que aumentarán enormemente el peso de la Plantilla, es por esta razón que debemos bajarla aún más.

Quitemos las imágenes de las pantallas de cada ventana. Excepto un triangulo que anda por ahí.

La imagen nos muestra el resultado, y vemos también la imagen del triangulo a la que me refería.

El Tiempo Estimado de Carga disminuye a 12 segundos, nada mal.
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A continuación hay que sustituir las imágenes con el mismo color. Posiciónate en alguna de las celdas cuya imagen de color eliminaste luego: Clic Botón Derecho del Ratón > Propiedades de Celda > Fondo, baja el sub-menú de color > Mas Colores > Seleccionar. Y ya con el gotero muestrea el color oscuro de la imagen del triangulo, que es el color de las imágenes borradas, o simplemente usa el siguiente valor: C3,C7,E5. En delante este valor estará cargado en los Colores del Documento, lo que significa que no será necesario muestrear nuevamente.
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DISEÑO Y MAQUETADO DE PLANTILLAS WEB 8 

Con Adobe Photoshop, Microsoft Front Page y Macromedia Dreamweaver

Continuamos con la octava entrega junto a Paquo360 que nos enseña como crear una plantilla usando Adobe Photoshop, y luego maquetarla,. pero como algunos usuarios lo han pedido, hicimos primero la Maquetacion en Microsoft Front Page :) y aqui termina para luego entrar a Macromedia DreamWeaver. 

Nota: Si bien fue desarrollado en Photoshop 6, se puede ejecutar en Photoshop CS 2 sin problemas, al igual que usar Dreamweaver 8 para el maquetado. !!

Clic Botón Derecho del Ratón > Propiedades de Celda > Estilo > Formato > Borde
No en todas las celdas se usarán los 4 lados, como en al caso de la mayor y su contigua superior, junto al triangulo.

Con esto homogeneizamos el borde aplicado en "Photoshop" en las zonas oscuras de la Plantilla.

[image: image49.png]



En el caso de la celda mayor hay que hacer lo siguiente para que aplique al borde oscuro: Clic Botón Derecho del Ratón > Propiedades de Celda
La imagen te muestra el resto (negro).
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Hay que modificar un poco los márgenes, lo cual es opcional. Clic Botón Derecho del Ratón > Propiedades de la Página > Márgenes (pestaña de)

Especifica el Margen Superior con 0 px.
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Sólo nos queda un detalle para terminar la Plantilla. La pequeña imagen de la esquina, esta debe ir a Hojalatería y Pintura en "Photoshop".

Hay varias formas de llevarla, pero la más simple es Clic Botón Derecho del ratón > Copiar.

Una vez en "Photoshop" File > New Ok Luego: Edit > Paste. Y listo, allí tienes la pequeña imagen.

Con la herramienta Line traza una línea color negro de 1 px entre la unión de los dos colores para simular borde negro de las celdas.

[image: image52.png]



Aprovecharemos esta parte del tutorial para echarle una mirada al comando Save for Web. Tenemos una imagen en "Photoshop" y debemos editarla de manera que su tamaño os permita utilizarla sin problemas en Internet. De cierta forma ya hicimos esto con "Image Ready", pero ahora le toca turno a "Photoshop".

File > Save for Web
Es muy importante recordar el nombre y en que carpeta se guarda la imagen que luego será usada en el Editor HTML
[image: image53.png]



Imagen anterior a Mayor Tamaño
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Finalmente hay que traer de regreso la imagen, ya pintada, y sobre todo optimizada.

Pon tu cursos sobre la celda donde se localiza esta imagen y luego insértala.

Para esto presiona [image: image55]luego [image: image56]para llegar hasta donde se localiza tu archivo.
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Esta es nuestra Plantilla Final que termina en 12 seg a 28.8 kb/seg lo que es una magnifica velocidad.

Te recomiendo que la veas el Resultado Final.

[image: image58.png]
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Con Adobe Photoshop, y Macromedia Dreamweaver

En esta novena entrega junto a Paquo360 llegamos a uno de los puntos mas esperados del tutorial, es el que mas han pedido los usuarios desde el comienzo, hablamos de maquetar la web con Macromedia DreamWeaver.

Abre tu diseño de Página, ahora en HTML. Dreamweaver, cuando esta en Vista Estándar [image: image59.png]


, contrario a Front Page, te presenta una página limpia, libre de tantas celdas, te la muestra casi como te la mostraría un navegador. Veamos pues como se vería en internet presionando F-12 en tu teclado.

Para respetar al camino que se siguió con F.P. 2000, cambiemos el color de fondo de nuestra página, sin embargo haremos una pequeña escala en el HTML para ordenarlo y limpiarlo de los malos tratos de Image Ready.

[image: image60.png]



Rápidamente demos un correcto formato al texto HTML pues Image Ready deja mucho que desear a la hora de escribir el código. Commands > Apply Source Formatting. Tal vez no distingas nada en la Vista del Diseño [image: image61.png]


, pero puedes apréciar los cambios en la Vista del Código [image: image62.png]


. Luego quitamos las marcas que Image Ready dejo: Commands > Clean Up HTML usas los parámetro de la imagen. Nos dice que removí y listo.
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Presiona Ok (Aceptar) y listo.

Continuemos pues con el Color de Fondo. Vamos a Modify > Page Properties y seleccionamos el color de fondo que hemos venido usando, escribiendo directamente el código para este color que es ECEDF7 o muestreando con el selector de color [image: image64.png]


.

De paso corregimos el Margen Superior (Top Margin) a un Valor = 0.

La imagen muestra las áreas donde se realizaron los cambios encuadradas de rojo.
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Ahora hay que alinear nuestra pagina al centro, lo cual es muy simple. Nos pasamos a la Vista Layout presionando su respectivo botón [image: image66.png]


.

Hacemos clic sobre la cresta principal del diseño [image: image67.png]


para luego usar la Inspector de Propiedades (Window > Properties) Activamos el Tag Editor (o selector de etiquetas) Luego clic sobre el signo + Luego sobre el Menú Tag y seleccionamos Align Finalmente escribimos Center sobre el renglón emergente terminando con un Enter en tu teclado.

Este es el resultado.
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[image: image69.png]SIE al B&icCoiR

— -~




Es hora de eliminar las imágenes del mismo color que el fondo de nuestra página. En algunos caso puede cambiar el tamaño de las cedas pero eso realmente poco afecta. Haz clic sobre las imágenes y presiona Supr (delete). Quitemos las imágenes de cada ventana.

Estas últimas sustitúyelas por color de fondo de celda, en este caso C3C7E5 que es el mismo color de las imagenes que las cubrían.

Toma la celda por cualquiera de los extremos y luego Sobre el Inspector de Propiedades cambia el Bg (background).
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[image: image71.png]
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Con Adobe Photoshop, y Macromedia Dreamweaver

Con esta decima entrega junto a Paquo360 llegamos al final de este tutorial, en el que hemos visto el diseño y maquetacion de una web utilizando Adobe Photoshop, Adobe ImageReady, Microsoft FrontPage o Macromedia DreamWeaver con el que terminamos ahora ...

Ahora seguimos con los bordes. hay que aclarara que esta no es la forma más común de crear los bordes de celda en este programas, sin embargo por haberlo hecho así con Front Page emularemos la técnica, es decir utilizaremos estilos con el HTML. Sé que a muchos no les agrada codificar sin embargo es esa la forma más correcta de crear para la web. Lo haremos en 4 pasos y uno extra para conocer mejor Dreamweaver; la imagen lo muestra:

1 Toma por el borde la celda en cuestión y destaca el Selector de Etiquetas.

2.- Presiona sobre el signo + para agregar una etiqueta a la celda seleccionada.

3.- Selecciona Style.

4.- Sobre el renglón emergente escribe el siguiente código, el cual he distinguido con cuatro colores para que aprecies en que parte de cada lado se aplicara el borde (border-bottom, etc) Negro (000000) y Sólido (solid)
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BORDER-BOTTOM: #000000 1px solid; BORDER-LEFT: #000000 1px solid; BORDER-RIGHT: #000000 1px solid; BORDER-TOP: #000000 1px solid

5.- Si presionas sobre el icono del lápiz sobre papel señalado con el #5 verás las etiquetas que la celda tiene hasta ahora.

Este método se utiliza cuando el borde es en los cuatro lados.

Hacemos lo mismo, agregar la etiqueta style, pero para esta celda solo se necesita el borde arriba y a la derecha. A la izquierda ves el código insertado: Nota la diferencia.
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BORDER-RIGHT: #000000 1px solid; BORDER-TOP: #000000 1px solid

Finalmente y para terminar el resto de la celda mayor, la parte baja, tómala y agrega el siguiente código con una Etiqueta Style: BORDER-BOTTOM: 1px solid; BORDER-LEFT: 1px solid; BORDER-RIGHT: 1px solid

Además la Etiqueta BorderColor: 000000 
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Nos queda un detalle para terminar la Plantilla. La pequeña imagen de la esquina, que será modificada en "Photoshop".

Hay varias formas de llevarla, pero la más simple es Clic > Botón Derecho del ratón > Copy.

Una vez en "Photoshop" File > New, Ok Luego: Edit > Paste. Y listo, allí tienes la pequeña imagen.

Con la herramienta Line traza una línea color negro de 1 px entre la unión de los dos colores para simular borde negro de las celdas. 

[image: image75.png]



Aprovecharemos esta parte del tutorial para echarle una mirada al comando Save for Web. Tenemos una imagen en "Photoshop" y debemos editarla de manera que su tamaño os permita utilizarla sin problemas en Internet. De cierta forma ya hicimos esto con "Image Ready", pero ahora le toca turno a "Photoshop".

File > Save for Web
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Finalmente hay que traer de regreso la imagen, ya pintada, y sobre todo optimizada.

Elimina la antigua imagen e inserta la nueva. Ve a Insert > Image navega hasta que la encuentres.

Es deseable que vuelvas a darle formato al HTML y lo limpies, como lo hicimos al principio.

Ya solo Guarda.
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